Addressing Table

DeviceInterfaceIPv4 Address/MaskIPv6 Address/PrefixIPv6 Link LocalDefault Gateway

R1e0/010.10.12.1/302001:db8:0:12::1/64fe80::1:1
s1/0N/A2001:db8:0:13::1/64fe80::1:3
e0/110.10.1.1/242001:db8:0:1::1/64fe80::1:2

R2e0/010.10.12.2/302001:db8:0:12::2/64fe80::2:1
e0/110.10.23.1/302001:db8:0:23::1/64fe80::2:2

R3e0/010.10.23.2/302001:db8:0:23::2/64fe80::3:1
s1/0N/A2001:db8:0:13::2/64fe80::3:3
e0/110.10.3.1/242001:db8:0:3::1/64fe80::3:2

DSw1VLAN 1010.10.1.2/24N/AN/A10.10.1.1

DSw2VLAN 1010.10.3.2/24N/AN/A10.10.3.1

PC1eth010.10.1.10/242001:db8:0:1::10/64EUI-6410.10.1.1
2001:db8:0:1::1

PC2eth010.10.1.20/242001:db8:0:1::20/64EUI-6410.10.1.1
2001:db8:0:1::1

Web_Servereth010.10.3.80/242001:db8:0:3::80/64EUI-6410.10.3.1
2001:db8:0:3::1

FTP_Servereth010.10.3.21/242001:db8:0:3::21/64EUI-6410.10.3.1
2001:db8:0:3::1

Set up PC1
Set up the pcname, the ipv4 and ipv6 address using the table above.

VPCS> set pcname PC1

PC1> ip 10.10.1.20/24 10.10.1.1
Checking for duplicate address…
PC1 : 10.10.1.20 255.255.255.0 gateway 10.10.1.1

PC1> ip 2001:db8:0:1::10/64 2001:db8:0:1::1
PC1 : 2001:db8:0:1::10/64

PC1> save
Saving startup configuration to startup.vpc
. done


Set up PC2
Set up the pcname, the ipv4 and ipv6 address using the table above.

VPCS> set pcname PC2

PC2> ip 10.10.1.20/24 10.10.1.1
Checking for duplicate address…
PC1 : 10.10.1.20 255.255.255.0 gateway 10.10.1.1

PC2> ip 2001:db8:0:1::20/64 2001:db8:0:1::1
PC1 : 2001:db8:0:1::20/64

PC2> save
Saving startup configuration to startup.vpc
. done


Set up Web_Server
Set up the pcname, the ipv4 and ipv6 address using the table above.

VPCS> set pcname Web

Web> ip 10.10.3.80/24 10.10.3.1
Checking for duplicate address…
PC1 : 10.10.3.80 255.255.255.0 gateway 10.10.3.1

Web> ip 2001:db8:0:3::80/64 2001:db8:0:3::1
PC1 : 2001:db8:0:3::80/64

Web> save
Saving startup configuration to startup.vpc
.  done


Set up FTP Server
Set up the pcname, the ipv4 and ipv6 address using the table above.

VPCS> set pcname FTP

FTP> ip 10.10.3.21/24 10.10.3.1
Checking for duplicate address…
PC1 : 10.10.3.21 255.255.255.0 gateway 10.10.3.1

FTP> ip 2001:db8:0:3::21/64 2001:db8:0:3::1
PC1 : 2001:db8:0:3::21/64

FTP> save
Saving startup configuration to startup.vpc
.  done

Configure the DSw1 switch
Change the hostname of the switch. Create VLAN 10 and name the VLAN Data-VLAN. Assign VLAN 10 the appropriate IP address using the table above. Configure the ports to use VLAN 10.

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname DSw1
DSw1(config)#vlan 10
DSw1(config-vlan)#name Data-VLAN
DSw1(config-vlan)#exit
DSw1(config)#interface vlan 10
DSw1(config-if)#ip address 10.10.1.2 255.255.255.0
DSw1(config-if)#no shutdown
DSw1(config-if)#exit
DSw1(config)#ip default-network 10.10.1.1
DSw1(config)#interface ethernet 0/0
DSw1(config-if)#switchport mode access
DSw1(config-if)#switchport access vlan 10
DSw1(config-if)#no shutdown
DSw1(config-if)#exit
DSw1(config)#interface range ethernet 1/2 - 3
DSw1(config-if-range)#switchport mode access
DSw1(config-if-range)#switchport access vlan 10
DSw1(config-if-range)#no shutdown
DSw1(config-if-range)#end

Configure the DSw2 switch
Change the hostname of the switch. Create VLAN 10 and name the VLAN Data-VLAN. Assign VLAN 10 the appropriate IP address using the table above. Configure the ports to use VLAN 10.

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname DSw2
DSw1(config)#vlan 10
DSw1(config-vlan)#name Data-VLAN
DSw2(config-vlan)#exit
DSw2(config)#interface vlan 10
DSw2(config-if)#ip address 10.10.3.2 255.255.255.0
DSw2(config-if)#no shutdown
DSw2(config-if)#exit
DSw2(config)#ip default-network 10.10.3.1
DSw2(config)#interface ethernet 0/0
DSw2(config-if)#switchport mode access
DSw2(config-if)#switchport access vlan 10
DSw2(config-if)#no shutdown
DSw2(config-if)#exit
DSw2(config)#interface range ethernet 1/2 - 3
DSw2(config-if-range)#switchport mode access
DSw2(config-if-range)#switchport access vlan 10
DSw2(config-if-range)#no shutdown
DSw2(config-if-range)#end

Configure the R1 router
Change the hostname of the router. Assign the IPv4 & IPv6 addresses using the table above. The serial interface should be encapsulated using PPP, and the clock rate set. Enable ipv6 unicast routing.

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface ethernet 0/0
R1(config-if)#ip address 10.10.12.1 255.255.255.252
R1(config-if)#ipv6 address 2001:db8:0:12::1/64
R1(config-if)#ipv6 address fe80::1:1 link-local
R1(config-if)#ipv6 enable
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 0/1
R1(config-if)#ip address 10.10.1.1 255.255.255.0
R1(config-if)#ipv6 address 2001:db8:0:1::1/64
R1(config-if)#ipv6 address fe80::1:2 link-local
R1(config-if)#ipv6 enable
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 1/0
R1(config-if)#encapsulation ppp
R1(config-if)#clock rate 8064000
R1(config-if)#ipv6 address 2001:db8:0:13::1/64
R1(config-if)#ipv6 address fe80::1:3 link-local
R1(config-if)#ipv6 enable
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ipv6 unicast-routing

Configure the R2 router
Change the hostname of the router. Assign the IPv4 & IPv6 addresses using the table above. Enable ipv6 unicast routing.

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface ethernet 0/0
R2(config-if)#ip address 10.10.12.2 255.255.255.252
R2(config-if)#ipv6 address 2001:db8:0:12::2/64
R2(config-if)#ipv6 address fe80::2:1 link-local
R2(config-if)#ipv6 enable
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface ethernet 0/1
R2(config-if)#ip address 10.10.23.1 255.255.255.252
R2(config-if)#ipv6 address 2001:db8:0:23::1/64
R2(config-if)#ipv6 address fe80::2:1 link-local
R2(config-if)#ipv6 enable
R2(config-if)#no shutdown

Configure the R3 router
Change the hostname of the router. Assign the IPv4 & IPv6 addresses using the table above. The serial interface should be encapsulated using PPP. Enable ipv6 unicast routing.

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface ethernet 0/0
R3(config-if)#ip address 10.10.23.2 255.255.255.252
R3(config-if)#ipv6 address 2001:db8:0:23::2/64
R3(config-if)#ipv6 address fe80::3:1 link-local
R3(config-if)#ipv6 enable
R3(config-if)#no shutdown
R3(config-if)#interface ethernet 0/1
R3(config-if)#ip address 10.10.3.1 255.255.255.0
R3(config-if)#ipv6 address 2001:db8:0:3::1/64
R3(config-if)#ipv6 address fe80::3:2 link-local
R3(config-if)#ipv6 enable
R3(config-if)#no shutdown
R3(config)#interface serial 1/0
R3(config-if)#encapsulation ppp
R3(config-if)#ipv6 address 2001:db8:0:13::2/64
R3(config-if)#ipv6 address fe80::3:3 link-local
R3(config-if)#ipv6 enable
R3(config-if)#no shutdown

Configure the IPv4 Static Routes
On router R1, send the data destined to R3 to R2. Add the route to subnet between R2 and R3 on R1.

R1(config)#ip route 10.10.3.0 255.255.255.0 10.10.12.2
R1(config)#ip route 10.10.23.0 255.255.255.252 10.10.12.2

On router R2, add the route destined to subnet 10.10.1.0 to routers R1 interface. Add the route destined to subnet 10.10.3.0 to routers R3 interface.

R2(config)#ip route 10.10.1.0 255.255.255.0 10.10.12.1
R2(config)#ip route 10.10.3.0 255.255.255.0 10.10.23.2

On router R3, send the data destined to R1 to R2. Add the route to subnet between R1 and R2.

R3(config)#ip route 10.10.1.0 255.255.255.0 10.10.23.1
R3(config)#ip route 10.10.12.0 255.255.255.252 10.10.23.1

Test on PC1
Ping using the IPv4 protocol the Web and FTP server.

PC1> ping 10.10.3.80

84 bytes from 10.10.3.80 icmp_seq=1 ttl=61 time=2.208 ms
84 bytes from 10.10.3.80 icmp_seq=2 ttl=61 time=2.157 ms
84 bytes from 10.10.3.80 icmp_seq=3 ttl=61 time=2.285 ms
84 bytes from 10.10.3.80 icmp_seq=4 ttl=61 time=2.762 ms
84 bytes from 10.10.3.80 icmp_seq=5 ttl=61 time=2.267 ms

PC1> ping 10.10.3.21

84 bytes from 10.10.3.21 icmp_seq=1 ttl=61 time=3.440 ms
84 bytes from 10.10.3.21 icmp_seq=2 ttl=61 time=2.627 ms
84 bytes from 10.10.3.21 icmp_seq=3 ttl=61 time=2.818 ms
84 bytes from 10.10.3.21 icmp_seq=4 ttl=61 time=2.630 ms
84 bytes from 10.10.3.21 icmp_seq=5 ttl=61 time=2.844 ms

Configure IPv6 Static Routes
On router R1, configure the static route for the 2001:db8:0:3::/64 prefix using the next-hop global unicast address of router R3. Add the route of the subnet between R2 and R3, using the next-hop global unicast address of router R2.

R1(config)#ipv6 route 2001:db8:0:3::/64 2001:db8:0:13::2
R1(config)#ipv6 route 2001:db8:0:23::/64 2001:db8:0:12::2

On router R2, configure the static route for the 2001:db8:0:1::/64 prefix using the next-hop global unicast address of router R1. Configure the static route for the 2001:db8:0:3::/64 prefix using the next-hop global unicast address of router R3.

R2(config)#ipv6 route 2001:db8:0:1::/64 2001:db8:0:12::1
R2(config)#ipv6 route 2001:db8:0:3::/64 2001:db8:0:23::2

On router R3, configure the static route for the 2001:db8:0:1::/64 prefix using the next-hop global unicast address of router R1. Add the route of the subnet between R1 and R2, using the next-hop global unicast address of router R2.

R3(config)#ipv6 route 2001:db8:0:1::/64 2001:db8:0:13::1
R3(config)#ipv6 route 2001:db8:0:12::/64 2001:db8:0:23::1

Test on PC1
Ping using the IPv6 protocol the Web and FTP server.

PC1> ping 2001:db8:0:3::80

2001:db8:0:3::80 icmp6_seq=1 ttl=58 time=5.274 ms
2001:db8:0:3::80 icmp6_seq=2 ttl=58 time=2.206 ms
2001:db8:0:3::80 icmp6_seq=3 ttl=58 time=2.513 ms
2001:db8:0:3::80 icmp6_seq=4 ttl=58 time=2.011 ms
2001:db8:0:3::80 icmp6_seq=5 ttl=58 time=2.530 ms

PC1> ping 2001:db8:0:3::21

2001:db8:0:3::21 icmp6_seq=1 ttl=58 time=8.001 ms
2001:db8:0:3::21 icmp6_seq=2 ttl=58 time=2.603 ms
2001:db8:0:3::21 icmp6_seq=3 ttl=58 time=2.389 ms
2001:db8:0:3::21 icmp6_seq=4 ttl=58 time=1.878 ms
2001:db8:0:3::21 icmp6_seq=5 ttl=58 time=1.972 ms

Leave a Reply